Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #964 PEAR_ERROR_EXCEPTION causes fatal error
Submitted: 2004-03-07 22:54 UTC
From: marthom at nortelnetworks dot com Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 5.0.0b4 (beta4) OS:
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 42 + 39 = ?

 
 [2004-03-07 22:54 UTC] marthom at nortelnetworks dot com
Description: ------------ PEAR_ERROR_EXCEPTION mode doesn't work, because PEAR_Error doesn't extend Exception. Reproduce code: --------------- require_once("PEAR.php"); PEAR::setErrorHandling(PEAR_ERROR_EXCEPTION); PEAR::raiseError("Hello World!"); Expected result: ---------------- The PEAR_Error class should be thrown as an exception. Actual result: -------------- [08-Mar-2004 09:50:26] PHP Fatal error: Exceptions must valid objects that are derived from class Exception in /usr/local/lib/php/PEAR.php(778) : eval()'d code on line 1

Comments

 [2004-03-07 23:00 UTC] marthom at nortelnetworks dot com
The OS makes no difference of course.
 [2004-04-03 06:20 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.