Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.11.5

Bug #940 whereAdd should return whereAdd string
Submitted: 2004-03-03 15:47 UTC
From: pear at daniu dot de Assigned: alan_k
Status: Closed Package: DB_DataObject
PHP Version: 4.3.4 OS: irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 36 - 31 = ?

 
 [2004-03-03 15:47 UTC] pear at daniu dot de
Description: ------------ I wish that whereAdd would return the current whereAdd string just like selectAdd does. This would help in some cases and sounds like a very small thing Thanks

Comments

 [2004-03-07 14:25 UTC] alan_k
sounds like a good idea to me..
 [2004-03-10 04:49 UTC] alan_k
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. please try and let me know if thats what was intended.. It returns the previous where statement, eg. $a->whereAdd('a=12'); echo $a->whereAdd('b=13'); // prints 'a=12' echo $a->whereAdd(); // resets it and prints 'a=12 and b=13'