Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #6991 Class 'PEAR_PackageFile_v1' not found in Registry.php at line 1657
Submitted: 2006-03-02 08:27 UTC
From: c dot pinkl at gmx dot at Assigned: cellog
Status: Closed Package: PEAR (version 1.4.7)
PHP Version: 5.0.5 OS: Win XP
Roadmaps: (Not assigned)    
Subscription  


 [2006-03-02 08:27 UTC] c dot pinkl at gmx dot at (Christoph Pinkl)
Description: ------------ The Error was while testing the PEAR_Frontend_web in the PEAR/Registry.php at line 1657 in the Function updatePackage. The class PEAR_PackageFile_v1 wasn't found. Other than in the function addPackage you do not try if the Class already exist. so Maybe it would help checking if the class exist and else incuding the needed file 'PEAR/PackageFile/v1.php'. Test script: --------------- Posible changes to the function updatePackage in Registry.php: Currently: $pf = new PEAR_PackageFile_v1; to if (!class_exists('PEAR_PackageFile_v1')) { require_once 'PEAR/PackageFile/v1.php'; } $pf = new PEAR_PackageFile_v1;

Comments

 [2006-03-02 18:14 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.