Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #6969 PEAR list-upgrades crashes
Submitted: 2006-03-01 10:07 UTC
From: RQuadling at GMail dot com Assigned: cellog
Status: Closed Package: PEAR (version 1.4.7)
PHP Version: 5.1.2 OS: Windows XP SP2 CLI
Roadmaps: (Not assigned)    
Subscription  


 [2006-03-01 10:07 UTC] RQuadling at GMail dot com (Richard Quadling)
Description: ------------ <01/03/2006 10:04:33 C:\>pear list-upgrades COMPONENTS.EZ.NO AVAILABLE UPGRADES (STABLE): ============================================= CHANNEL PACKAGE LOCAL REMOTE SIZE components.ez.no Cache 1.0 (stable) 1.0.1 (stable) 17.6kB components.ez.no eZComponents 1.0 (stable) 1.0.1 (stable) 1.7kB components.ez.no ImageAnalysis 1.0 (stable) 1.0.1 (stable) 177kB components.ez.no ImageConversion 1.0 (stable) 1.0.1 (stable) 196kB Channel pear.php.net: No upgrades available Fatal error: Call to a member function lastModified() on a non-object in C:\PEAR\pear\PEAR\Command\Remote.php on line 164 and <01/03/2006 10:06:40 C:\>pear upgrade-all Will upgrade cache Will upgrade ezcomponents Will upgrade imageanalysis Will upgrade imageconversion Fatal error: Call to a member function supportsREST() on a non-object in C:\PEAR\pear\PEAR\Command\Install.php on line 374

Comments

 [2006-03-01 10:08 UTC] RQuadling at GMail dot com
Prior to upgrading to PEAR V1.4.7 ... <01/03/2006 9:23:26 C:\>pear list-upgrades COMPONENTS.EZ.NO AVAILABLE UPGRADES (STABLE): ============================================= CHANNEL PACKAGE LOCAL REMOTE SIZE components.ez.no Cache 1.0 (stable) 1.0.1 (stable) 17.6kB components.ez.no eZComponents 1.0 (stable) 1.0.1 (stable) 1.7kB components.ez.no ImageAnalysis 1.0 (stable) 1.0.1 (stable) 177kB components.ez.no ImageConversion 1.0 (stable) 1.0.1 (stable) 196kB PEAR.PHP.NET AVAILABLE UPGRADES (STABLE): ========================================= CHANNEL PACKAGE LOCAL REMOTE SIZE pear.php.net PEAR 1.4.6 (stable) 1.4.7 (stable) 274kB Channel pear.symfony-project.com: No upgrades available I've done a PEAR INSTALL -f PEAR and this has not made any difference to the subsequent errors.
 [2006-03-02 00:35 UTC] soporte at onfocus dot cl (Cristian Rodriguez)
I have reproduced the pear upgrae-all problem crash on linux /php 5.1.3-dev too. same fatal error.
 [2006-03-02 01:30 UTC] cellog
this is directly related to Bug #6960, as you have "pear.symfony-project.com" in your channels. For some reason, this slipped through the cracks. As a temporary fix, simply apply the patch found in #6960 and the crash will disappear. This bug is not a duplicate of #6960, as there should be NO crashes for any reason.
 [2006-03-02 08:48 UTC] RQuadling at GMail dot com
Yep! Patched working as expected. <02/03/2006 8:39:58 C:\>pear list-upgrades COMPONENTS.EZ.NO AVAILABLE UPGRADES (STABLE): ============================================= CHANNEL PACKAGE LOCAL REMOTE SIZE components.ez.no Cache 1.0 (stable) 1.0.1 (stable) 17.6kB components.ez.no eZComponents 1.0 (stable) 1.0.1 (stable) 1.7kB components.ez.no ImageAnalysis 1.0 (stable) 1.0.1 (stable) 177kB components.ez.no ImageConversion 1.0 (stable) 1.0.1 (stable) 196kB PEAR.PHP.NET AVAILABLE UPGRADES (STABLE): ========================================= CHANNEL PACKAGE LOCAL REMOTE SIZE pear.php.net Benchmark 1.2.5 (stable) 1.2.6 (stable) 7.7kB Channel pear.symfony-project.com: No upgrades available <02/03/2006 8:43:30 C:\>pear upgrade-all Will upgrade cache Will upgrade ezcomponents Will upgrade imageanalysis Will upgrade imageconversion Will upgrade benchmark downloading Cache-1.0.1.tgz ... Starting to download Cache-1.0.1.tgz (18,014 bytes) ......done: 18,014 bytes downloading eZComponents-1.0.1.tgz ... Starting to download eZComponents-1.0.1.tgz (1,661 bytes) ...done: 1,661 bytes downloading ImageAnalysis-1.0.1.tgz ... Starting to download ImageAnalysis-1.0.1.tgz (180,667 bytes) ...done: 180,667 bytes downloading ImageConversion-1.0.1.tgz ... Starting to download ImageConversion-1.0.1.tgz (200,054 bytes) ...done: 200,054 bytes downloading Benchmark-1.2.6.tgz ... Starting to download Benchmark-1.2.6.tgz (7,915 bytes) ...done: 7,915 bytes upgrade-all ok: channel://pear.php.net/Benchmark-1.2.6 upgrade-all ok: channel://components.ez.no/ImageConversion-1.0.1 upgrade-all ok: channel://components.ez.no/ImageAnalysis-1.0.1 upgrade-all ok: channel://components.ez.no/eZComponents-1.0.1 upgrade-all ok: channel://components.ez.no/Cache-1.0.1
 [2006-03-02 12:44 UTC] pajoye
I suggest a 1.7.1 with this fix asap, many channels may suffer from this problem.
 [2006-03-02 12:44 UTC] pajoye
1.4.8 is what I mean :)
 [2006-03-02 16:11 UTC] cellog
agreed
 [2006-03-02 17:22 UTC] cellog
I have a working patch that not only fixes the problem but has a helpful error message on any future debacle instead of a crash. Upgrading to critical
 [2006-03-02 18:14 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.