Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #6273 pear download-all fails
Submitted: 2005-12-17 06:57 UTC
From: toggg Assigned: cellog
Status: Closed Package: PEAR
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2005-12-17 06:57 UTC] toggg
Description: ------------ pear download-all fails to download any .tgz Looks like it's comuting on pecl after failing (stangely) on Archive_Zip , or is it only a wrong message ? Tested on 2 installations: Thanks vpainz on irc: C:\php>pear -V PEAR Version: 1.4.5 PHP Version: 5.1.1 Zend Engine Version: 2.1.0 Running on: Windows NT NETZONE-8 5.1 build 2600 same here: # pear -V PEAR Version: 1.4.6 (CVS up to date) PHP Version: 4.3.11 Zend Engine Version: 1.3.0 Running on: Linux ancilla.toggg.net 2.6.12-1.1381_FC3 #1 Fri Oct 21 03:46:55 EDT 2005 i686 Test script: --------------- # pear download-all or even # pear download-all -c pear.php.net Expected result: ---------------- Download all package.tgz within preferred state (stable) Actual result: -------------- [root@ancilla test]# pear download-all Using Channel pear.php.net Failed to download pear/Archive_Zip within preferred state "stable", latest release is version 0.1.1, stability "beta", use "channel://pear.php.net/Archive_Zip-0.1.1" to install Cannot initialize 'Archive_Zip', invalid or missing package file No releases available for package "pear.php.net/Auth_HTTP" Cannot initialize 'Auth_HTTP', invalid or missing package file No releases available for package "pecl.php.net/Auth_PrefManager" Cannot initialize 'Auth_PrefManager', invalid or missing package file No releases available for package "pecl.php.net/Auth_PrefManager2" Cannot initialize 'Auth_PrefManager2', invalid or missing package file No releases available for package "pecl.php.net/Auth_RADIUS" Cannot initialize 'Auth_RADIUS', invalid or missing package file No releases available for package "pecl.php.net/Auth_SASL" Cannot initialize 'Auth_SASL', invalid or missing package file No releases available for package "pecl.php.net/Benchmark" Cannot initialize 'Benchmark', invalid or missing package file No releases available for package "pecl.php.net/Cache" Cannot initialize 'Cache', invalid or missing package file No releases available for package "pecl.php.net/Cache_Lite" Cannot initialize 'Cache_Lite', invalid or missing package file No releases available for package "pecl.php.net/Calendar" Cannot initialize 'Calendar', invalid or missing package file ------- Control C ------ [root@ancilla test]# ls [root@ancilla test]#

Comments

 [2005-12-24 11:33 UTC] toggg
Returning to this one, I understood we just did not wait enough ... it's actually downloading al stable packages. The bunch of warnings at the beginning are *warnings*... Indeed, the REST mechanism is based on http://pear.php.net/rest/p/packages.xml which lists *all* packages not taking into account their states (in opposition to the previous xml_rpc "package.listAll" which was considering it) (see $remoteInfo in PEAR/Command/Mirror.php) So this mechanism needs a post checking of each package's state, that's what produces these warnings and takes so much time. (made for each of the unstable packages) After that, the downloads are OK... untill Net_FTP where it breaks... missing the following stables. Moreover this "bad filtered" warnings, I wonder if the mechanism is usable. At least some messages/progress should be given to the user if this command stays so slow. Note that the warnings seem somewhat random, skipping from pear.php.net to pecl.php.net, starting to do more warning then reduced to the last line ... .... Cannot initialize 'MDB2_Schema', invalid or missing package file Failed to download pear/Message within preferred state "stable", latest release is version 0.6, stability "beta", use "channel://pear.php.net/Message-0.6" to install Cannot initialize 'Message', invalid or missing package file Failed to download pear/MP3_Playlist within preferred state "stable", latest release is version 0.5.0alpha1, stability "alpha", use "channel://pear.php.net/MP3_Playlist-0.5.0alpha1" to install Cannot initialize 'MP3_Playlist', invalid or missing package file Failed to download pear/Net_Cyrus within preferred state "stable", latest release is version 0.3.1, stability "beta", use "channel://pear.php.net/Net_Cyrus-0.3.1" to install Cannot initialize 'Net_Cyrus', invalid or missing package file Failed to download pear/Net_DIME within preferred state "stable", latest release is version 0.3, stability "beta", use "channel://pear.php.net/Net_DIME-0.3" to install Cannot initialize 'Net_DIME', invalid or missing package file No releases available for package "pear.php.net/Net_FTP2" Cannot initialize 'Net_FTP2', invalid or missing package file No releases available for package "pecl.php.net/Net_GameServerQuery" Cannot initialize 'Net_GameServerQuery', invalid or missing package file No releases available for package "pecl.php.net/Net_Geo" Cannot initialize 'Net_Geo', invalid or missing package file .... No releases available for package "pecl.php.net/XML_XSLT_Wrapper" Cannot initialize 'XML_XSLT_Wrapper', invalid or missing package file No releases available for package "pecl.php.net/XML_XUL" Cannot initialize 'XML_XUL', invalid or missing package file downloading Archive_Tar-1.3.1.tgz ... Starting to download Archive_Tar-1.3.1.tgz (15,102 bytes) .....done: 15,102 bytes .... downloading Net_FTP-1.3.1.tgz ... Starting to download Net_FTP-1.3.1.tgz (19,373 bytes) ...done: 19,373 bytes Package "Archive_Zip" is not valid Package "Auth_PrefManager2" is not valid Package "Calendar" is not valid Package "CodeGen" is not valid Package "CodeGen_MySQL_UDF" is not valid Package "CodeGen_PECL" is not valid Package "Console_Color" is not valid Package "Console_ProgressBar" is not valid Package "Contact_AddressBook" is not valid Package "Date_Holidays" is not valid Package "DBA_Relational" is not valid Package "DB_DataObject_FormBuilder" is not valid Package "DB_ldap2" is not valid Package "DB_Sqlite_Tools" is not valid Package "File_DICOM" is not valid Package "File_DNS" is not valid Package "File_Fortune" is not valid Package "File_Gettext" is not valid Package "File_IMC" is not valid Package "File_Ogg" is not valid Package "File_PDF" is not valid Package "File_XSPF" is not valid Package "Games_Chess" is not valid Package "Genealogy_Gedcom" is not valid Package "Gtk_MDB_Designer" is not valid Package "Gtk_Styled" is not valid Package "Gtk_VarDump" is not valid Package "HTML_AJAX" is not valid Package "HTML_Common2" is not valid Package "HTML_Page" is not valid Package "HTML_Page2" is not valid Package "HTML_QuickForm_SelectFilter" is not valid Package "HTML_Safe" is not valid Package "HTML_Select" is not valid Package "HTTP_Server" is not valid Package "HTTP_Session" is not valid Package "HTTP_Session2" is not valid Package "HTTP_SessionServer" is not valid Package "HTTP_WebDAV_Client" is not valid Package "HTTP_WebDAV_Server" is not valid Package "I18N" is not valid Package "I18Nv2" is not valid Package "I18N_UnicodeString" is not valid Package "Image_3D" is not valid Package "Image_Canvas" is not valid Package "Image_Color2" is not valid Package "Image_Graph" is not valid Package "Image_MonoBMP" is not valid Package "Image_Text" is not valid Package "Image_Tools" is not valid Package "Image_Transform" is not valid Package "Image_XBM" is not valid Package "Inline_C" is not valid Package "LiveUser" is not valid Package "LiveUser_Admin" is not valid Package "Mail_IMAP" is not valid Package "Mail_IMAPv2" is not valid Package "Mail_Mbox" is not valid Package "Math_BinaryUtils" is not valid Package "Math_Complex" is not valid Package "Math_Finance" is not valid Package "Math_Fraction" is not valid Package "Math_Histogram" is not valid Package "Math_Numerical_RootFinding" is not valid Package "Math_Quaternion" is not valid Package "Math_Vector" is not valid Package "MDB2" is not valid Package "MDB2_Driver_fbsql" is not valid Package "MDB2_Driver_ibase" is not valid Package "MDB2_Driver_mssql" is not valid Package "MDB2_Driver_mysql" is not valid Package "MDB2_Driver_mysqli" is not valid Package "MDB2_Driver_oci8" is not valid Package "MDB2_Driver_pgsql" is not valid Package "MDB2_Driver_querysim" is not valid Package "MDB2_Driver_sqlite" is not valid Package "MDB2_Schema" is not valid Package "Message" is not valid Package "MP3_Playlist" is not valid Package "Net_Cyrus" is not valid Package "Net_DIME" is not valid Package "Net_FTP2" is not valid Package "Net_GameServerQuery" is not valid Package "Net_Geo" is not valid Package "Net_GeoIP" is not valid Package "Net_HL7" is not valid Package "Net_Ident" is not valid Package "Net_IDNA" is not valid Package "Net_IMAP" is not valid Package "Net_IPv4" is not valid Package "Net_IPv6" is not valid Package "Net_IRC" is not valid Package "Net_LDAP" is not valid Package "Net_LMTP" is not valid Package "Net_Monitor" is not valid Package "Net_NNTP" is not valid Package "Net_Ping" is not valid Package "Net_POP3" is not valid Package "Net_Portscan" is not valid Package "Net_Server" is not valid Package "Net_Sieve" is not valid Package "Net_SmartIRC" is not valid Package "Net_SMPP" is not valid Package "Net_SMPP_Client" is not valid Package "Net_SMS" is not valid Package "Net_SMTP" is not valid Package "Net_Socket" is not valid Package "Net_Traceroute" is not valid Package "Net_URL" is not valid Package "Net_UserAgent_Detect" is not valid Package "Net_UserAgent_Mobile" is not valid Package "Net_Whois" is not valid Package "Net_Wifi" is not valid Package "Numbers_Roman" is not valid Package "Numbers_Words" is not valid Package "OLE" is not valid Package "Pager" is not valid Package "Pager_Sliding" is not valid Package "Payment_Clieop" is not valid Package "Payment_DTA" is not valid Package "Payment_Process" is not valid Package "PEAR" is not valid Package "PEAR_Delegator" is not valid Package "PEAR_ErrorStack" is not valid Package "PEAR_Frontend_Gtk" is not valid Package "PEAR_Frontend_Gtk2" is not valid Package "PEAR_Frontend_Web" is not valid Package "PEAR_Info" is not valid Package "PEAR_PackageFileManager" is not valid Package "PEAR_PackageFileManager_GUI_Gtk" is not valid Package "PEAR_RemoteInstaller" is not valid Package "PHPDoc" is not valid Package "PhpDocumentor" is not valid Package "PHPUnit" is not valid Package "PHPUnit2" is not valid Package "PHP_Archive" is not valid Package "PHP_Beautifier" is not valid Package "PHP_Compat" is not valid Package "PHP_CompatInfo" is not valid Package "PHP_Fork" is not valid Package "PHP_Parser" is not valid Package "RDF" is not valid Package "RDF_N3" is not valid Package "RDF_NTriple" is not valid Package "RDF_RDQL" is not valid Package "Science_Chemistry" is not valid Package "ScriptReorganizer" is not valid Package "Search_Mnogosearch" is not valid Package "Services_Amazon" is not valid Package "Services_Delicious" is not valid Package "Services_DynDNS" is not valid Package "Services_Ebay" is not valid Package "Services_ExchangeRates" is not valid Package "Services_Google" is not valid Package "Services_Pingback" is not valid Package "Services_Technorati" is not valid Package "Services_Trackback" is not valid Package "Services_Weather" is not valid Package "Services_Webservice" is not valid Package "Services_Yahoo" is not valid Package "SOAP" is not valid Package "SOAP_Interop" is not valid Package "Spreadsheet_Excel_Writer" is not valid Package "SQL_Parser" is not valid Package "Stream_SHM" is not valid Package "Stream_Var" is not valid Package "Structures_DataGrid" is not valid Package "Structures_Graph" is not valid Package "System_Command" is not valid Package "System_Mount" is not valid Package "System_ProcWatch" is not valid Package "System_SharedMemory" is not valid Package "System_Socket" is not valid Package "System_WinDrives" is not valid Package "Text_CAPTCHA" is not valid Package "Text_Diff" is not valid Package "Text_Figlet" is not valid Package "Text_Highlighter" is not valid Package "Text_Huffman" is not valid Package "Text_Password" is not valid Package "Text_Statistics" is not valid Package "Text_TeXHyphen" is not valid Package "Text_Wiki" is not valid Package "Text_Wiki_BBCode" is not valid Package "Text_Wiki_Cowiki" is not valid Package "Text_Wiki_Doku" is not valid Package "Text_Wiki_Mediawiki" is not valid Package "Text_Wiki_Tiki" is not valid Package "Translation" is not valid Package "Translation2" is not valid Package "Tree" is not valid Package "UDDI" is not valid Package "Validate" is not valid Package "Validate_AT" is not valid Package "Validate_AU" is not valid Package "Validate_BE" is not valid Package "Validate_CA" is not valid Package "Validate_CH" is not valid Package "Validate_DE" is not valid Package "Validate_DK" is not valid Package "Validate_ES" is not valid Package "Validate_Finance" is not valid Package "Validate_Finance_CreditCard" is not valid Package "Validate_FR" is not valid Package "Validate_IS" is not valid Package "Validate_ISPN" is not valid Package "Validate_NL" is not valid Package "Validate_PL" is not valid Package "Validate_ptBR" is not valid Package "Validate_UK" is not valid Package "Validate_US" is not valid Package "Validate_ZA" is not valid Package "Var_Dump" is not valid Package "VersionControl_SVN" is not valid Package "VFS" is not valid Package "XML_Beautifier" is not valid Package "XML_CSSML" is not valid Package "XML_DTD" is not valid Package "XML_FastCreate" is not valid Package "XML_Feed_Parser" is not valid Package "XML_fo2pdf" is not valid Package "XML_FOAF" is not valid Package "XML_HTMLSax" is not valid Package "XML_HTMLSax3" is not valid Package "XML_image2svg" is not valid Package "XML_Indexing" is not valid Package "XML_MXML" is not valid Package "XML_NITF" is not valid Package "XML_Parser" is not valid Package "XML_RDDL" is not valid Package "XML_RPC" is not valid Package "XML_RPC2" is not valid Package "XML_RSS" is not valid Package "XML_SaxFilters" is not valid Package "XML_Serializer" is not valid Package "XML_sql2xml" is not valid Package "XML_Statistics" is not valid Package "XML_SVG" is not valid Package "XML_svg2image" is not valid Package "XML_Transformer" is not valid Package "XML_Tree" is not valid Package "XML_Util" is not valid Package "XML_Wddx" is not valid Package "XML_XPath" is not valid Package "XML_XSLT_Wrapper" is not valid Package "XML_XUL" is not valid download failed
 [2006-01-23 19:06 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. The problem was in PEAR_Downloader::_getPackageDownloadUrl() which was not restoring the default channel in case of an error returned from getDownloadURL() of PEAR_Remote or PEAR_REST In addition, I removed all the extra stuff caused by preferred_state, so output is very un-verbose. It is really much better now :)
 [2006-01-24 07:16 UTC] toggg
I updated to cvs: # pear -V PEAR Version: 1.4.7 PHP Version: 4.3.11 Zend Engine Version: 1.3.0 Running on: Linux ancilla.toggg.net 2.6.12-1.1381_FC3 #1 Fri Oct 21 03:46:55 EDT 2005 i686 # pear download-all Using Channel pear.php.net Using Preferred State of stable Gathering release information, please wait... No releases available for package "pear.php.net/Net_FTP2" Cannot initialize 'Net_FTP2', invalid or missing package file No releases available for package "pear.php.net/PEAR_Command_Packaging" Cannot initialize 'PEAR_Command_Packaging', invalid or missing package file No releases available for package "pear.php.net/PEAR_ErrorStack" Cannot initialize 'PEAR_ErrorStack', invalid or missing package file No releases available for package "pear.php.net/Validate_AU" Cannot initialize 'Validate_AU', invalid or missing package file downloading Archive_Tar-1.3.1.tgz ... Starting to download Archive_Tar-1.3.1.tgz (15,102 bytes) .....done: 15,102 bytes downloading Auth-1.2.3.tgz ... Starting to download Auth-1.2.3.tgz (24,040 bytes) ...done: 24,040 bytes .... <snip> .... Starting to download HTTP_Header-1.2.0.tgz (10,440 bytes) ...done: 10,440 bytes downloading HTTP_Request-1.3.0.tgz ... Starting to download HTTP_Request-1.3.0.tgz (13,808 bytes) ...done: 13,808 bytes PHP Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 55 bytes) in /usr/share/pear/PEAR/PackageFile/Parser/v1.php on line 134 so it's failing. # peardev download-all makes the same warnings but download thru: .... <snip> .... downloading XML_Wddx-1.0.1.tgz ... Starting to download XML_Wddx-1.0.1.tgz (3,911 bytes) ...done: 3,911 bytes downloading XML_XPath-1.2.3.tgz ... Starting to download XML_XPath-1.2.3.tgz (19,179 bytes) ...done: 19,179 bytes Package "Net_FTP2" is not valid Package "PEAR_Command_Packaging" is not valid Package "PEAR_ErrorStack" is not valid Package "Validate_AU" is not valid download failed ls | wc gives me 161 packages downloaded, looks right.
 [2006-01-24 15:17 UTC] cellog
if you are doing something as insane as download-all, you will be willing to either use peardev or disable memory_limit. It does not fail.
 [2006-01-26 01:09 UTC] toggg
I confirm my total agreement on that. This download-all command should be withdrawn from pear As said, any bash user can awk a pear remote-list and do it by h(er|im)self. Please, don't classify us as insane for that.