Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.0

Bug #625 popexpecterror error with Oracle
Submitted: 2004-01-26 05:16 UTC
From: thierrybo Assigned: lsmith
Status: Closed Package: MDB
PHP Version: 4.3.2 OS: Win32XP
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 33 + 9 = ?

 
 [2004-01-26 05:16 UTC] thierry dot bo at netcourrier dot com
Description: ------------ Hi, Since I found Oracle SID need to be set as 'host' in DSN, connection works fine, but each time I want to insert data, I get this error : Fatal error: Call to undefined function: popexpecterror() in F:\httpd\php\pear\MDB\Common.php on line 3565 I did not found this function somewhere. Thierry Bothorel (MDB 1.2) Reproduce code: --------------- $area_name_q = unslashes($name); $id = $mdb->nextId('mrbs_area_id'); if (MDB::isError($id)) { fatal_error(1, "<p>" . $id->getMessage() . "<br>" . $id->getUserInfo()); } $sql = "INSERT INTO mrbs_area (id, area_name) VALUES ($id, " . $mdb->getTextValue ($area_name_q) . ")"; $res = $mdb->query($sql); if (MDB::isError($res)) { fatal_error(1, "<p>" . $res->getMessage() . "<br>" . $res->getUserInfo()); } $area = $mdb->currId('mrbs_area_id'); Expected result: ---------------- new row in table. Works with Mysql, Mssql and pgsql Actual result: -------------- Fatal error: Call to undefined function: popexpecterror() in F:\httpd\php\pear\MDB\Common.php on line 3565

Comments

 [2004-01-26 09:23 UTC] lsmith
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.