Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #5854 if no installconditions match, no error is raised
Submitted: 2005-11-03 05:55 UTC
From: vshivak Assigned: cellog
Status: Closed Package: PEAR
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-11-03 05:55 UTC] vshivak
Description: ------------ It is possible to successfully install a package that contains no files by ignoring all of them. It's probably bug in OS_Guess, where (*ix|*ux|darwin*|SunOS*) is not selecting linux when used as an installcondition in package description. Real life situation. I've a package which contains only one BASH script (file role=script) and is only for Linux. By specifying installcondition for that file <installconditions> <os> <name>(*ix|*ux|darwin*|SunOS*)</name> </os> </installconditions> everything seems fine, 'pear package-validate' validates the package, but then when I install the package to pear repository (installation run with ok result) and run 'pear list-files MYPACKAGENAME' it shows me zero files installed and really script is not installed.

Comments

 [2005-11-12 06:39 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. it turns out, this is expected behavior. See http://pear.php.net/manual/en/guide.developers.package2.dependencies.php The problem is that it should let you know that your installcondition is bogus. I've changed the bug subject to reflect the problem, and added an error catch in PEAR_PackageFile_v2 that should do the trick.
 [2005-11-12 06:39 UTC] cellog
this is a PEAR bug, not a documentation bug