Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #5810 internet should not be contacted on install if dependencies are installed
Submitted: 2005-10-28 12:45 UTC
From: techtonik Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 4.4.0 OS: Windows 2000
Roadmaps: (Not assigned)    
Subscription  


 [2005-10-28 12:45 UTC] techtonik
Description: ------------ If you installing a package from a local archive and your system doesn't not have a route to a pear web-site it takes a long time to spit any status message, even the one displayed in "Actual result". It took about 2-3 minutes. Why pear have to access internet to install local package? Is it already turned spyware? =) Test script: --------------- C:\PHP>pear.bat install Image_Canvas-0.2.2.tgz Actual result: -------------- Skipping package "pear/Image_Canvas", already installed as version 0.2.2 No valid packages found install failed

Comments

 [2005-10-28 15:04 UTC] cellog
wrong bug title You do understand how pear works, right? it contacts the internet to determine the dependencies to download/install, and which version
 [2005-10-28 18:03 UTC] cellog
this bug will be deferred to PEAR 1.4.4
 [2005-10-29 05:55 UTC] techtonik
No, I do not understand how it works, because AFAIK you do not have a description or scheme of this process. In any case 2 minutes for a ping timeout is a bad behavior. Dependencies should be included in package.xml, shouldn't they?
 [2005-10-29 21:29 UTC] cellog
Thank you for taking the time to write to us, but this is not a bug. better summary
 [2005-10-29 21:29 UTC] cellog
not bogus
 [2005-10-29 22:37 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2005-10-31 21:06 UTC] techtonik
Thank god it was not considered bogus. At first comment I thought it was a revenge. =) BTW, how about to decrease server ping timeout? (sorry, I do not have time to study the code)