Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #5619 pear makerpm produces invalid .spec dependancy code
Submitted: 2005-10-06 21:11 UTC
From: glen at delfi dot ee Assigned: cellog
Status: Closed Package: PEAR
PHP Version: Irrelevant OS: PLD Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 41 = ?

 
 [2005-10-06 21:11 UTC] glen at delfi dot ee
Description: ------------ pear makerpm PEAR produces line in .spec Conflicts: php-pear-PEAR_Frontend_Web != 0.5.0 this is 1. invalid for .spec 2. it is produced in case where it's not neccessary needed, because $dep['conflicts'] is present in array but empty. here's fix for the #2, not sure for #1. http://glen.alkohol.ee/pld/PEAR-makerpm1.patch

Comments

 [2005-10-06 21:32 UTC] cellog
thanks for the patch. In fact, it is correct. The <conflicts/> tag transforms the entire dependency into a reverse dependency, which means it disallows all versions that are not present, so this should be producing a dependency that conflicts with all versions <= 0.5.0 except for version 0.5.0. The problem is that this results in the wrong thing (conflicts with all versions != 0.5.0), it should translate to a "conflicts with all versions < 0.5.0", so the logic in converting the dependency needs to be overhauled to generate a set of versions and then put that set into RPM terms
 [2005-10-08 23:45 UTC] cellog
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.