Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a4

Bug #470 weekOfYear - wrong result
Submitted: 2003-12-20 23:07 UTC
From: yyyy at stod dot de Assigned:
Status: Bogus Package: Date
PHP Version: 4.3.4 OS: win xp
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 25 - 25 = ?

 
 [2003-12-20 23:07 UTC] yyyy at stod dot de
Description: ------------ "weekOfYear" will produce wrong results. echo "Heutiges Datum KW: ".$DateTest->weekOfYear($DateTest->dateNow("22,12,2003")); produces: 51 Regards Ben Reproduce code: --------------- echo "Heutiges Datum KW: ".$DateTest->weekOfYear($DateTest->dateNow("22,12,2003")); Expected result: ---------------- Result should be: 52 if your week begins on monday.

Comments

 [2003-12-21 13:25 UTC] pajoye
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR. Cannot reproduce and works with latest release (1.4RC1 beta)