Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #4354 Remote PEAR upgrade and uninstall operation fail
Submitted: 2005-05-16 01:44 UTC
From: clay Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 5.0.4 OS: Debian Sarge
Roadmaps: (Not assigned)    
Subscription  


 [2005-05-16 01:44 UTC] clay
Description: ------------ Remote PEAR operations 'upgrade' and 'uninstall' produce fatal errors. I am operating on a remote server using the remote_config properties of PEAR 1.4.0a11. Installing new packages works without a problem. However, upgrading packages or attempting to remove packages results in: Fatal error: Call to a member function getPackage() on a non-object in /usr/share/php/PEAR/Installer.php on line 1265 The same error occurs in both upgrade and uninstall actions.

Comments

 [2005-05-19 14:46 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.