Report new bug | New search | Development Roadmap Status: Open | Feedback | All

Bug #3437 Wrong method name in example
Submitted: 2005-02-11 17:51 UTC
From: twinther at chello dot no Assigned: mj
Status: Bogus Package: Documentation
PHP Version: Irrelevant OS: irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 36 + 10 = ?

 
 [2005-02-11 17:51 UTC] twinther at chello dot no
Description: ------------ Hi, this is what I assume is an error in the code listing for 'Example 21-1, Typical usage example for PEAR::Auth', PEAR::Auth, on the page called 'Introduction'. A method that doesn't exist in the class is called on line 22. Reproduce code: --------------- if ($a->checkAuth()) { /** * The output of your site goes here. */ } Expected result: ---------------- An error reporting that checkAuth() is a non-existing method. The code, I guess, should be: if ($a->getAuth()) { /** * The output of your site goes here. */ }

Comments

 [2005-02-11 19:18 UTC] danielc
In addition, "/**" indicates the start of a docblock. "/*" should be used throughout the examples unless the comment really is a docblock.
 [2005-02-24 16:31 UTC] mj
The checkAuth() method exists. Can you please post the code with which you can reproduce this problem?
 [2005-10-23 17:37 UTC] danielc
Reporter seems to be mistaken or using an outdated version.