Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.2.16

Request #2992 New autocomplete method which works like google suggest
Submitted: 2004-12-20 02:46 UTC
From: php at mithis dot com Assigned:
Status: Wont fix Package: HTML_QuickForm
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 8 + 3 = ?

 
 [2004-12-20 02:46 UTC] php at mithis dot com
Description: ------------ This provides a new component to QuickForm called "hugecomplete" which works similar to google suggest (only using IFrames instead of XMLHttp stuff). It works pretty well but still needs a tiny bit of work. Thought I would submit it to hopefully get included in the main package one day. It does however require an extra page outside the normal form to function correctly. All feedback is welcome and would be appreciated. Reproduce code: --------------- http://www.mithis.com/php/hugecomplete.phps The code to produce the hugecomplete element. http://www.mithis.com/php/echo.phps The code for the hugecomplete iframe box.

Comments

 [2004-12-28 20:11 UTC] avb
Please propose this element as a subpackage for QuickForm. In this case you'll be able to develop and release it separately, which may be needed since its stability level is lower than that of the whole package.