Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.2

Bug #2882 TreeMenu not displayed in browser
Submitted: 2004-12-03 11:59 UTC
From: patrick dot tissot at airbus dot com Assigned:
Status: Bogus Package: HTML_TreeMenu
PHP Version: 5.0.2 OS: windows 2000
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 20 - 9 = ?

 
 [2004-12-03 11:59 UTC] patrick dot tissot at airbus dot com
Description: ------------ I call a PHP page that contains an HTML_TreeMenu built from an XML file. But nothing is displayed on my browser. However when I right click on the html page an select 'view source code' I can see that the tree is succesfully generated (see html code below), but it is not displayed: I got a white page. I am on IE 6.0.2800. Do you have any answer to my problem? Do you think it is linked to my browser version (IE 6.0.2800)? Thank you very much Patrick TISSOT Reproduce code: --------------- <html> <head> <link rel="stylesheet" href="css/EDMS.css" type="text/css"> <link rel="stylesheet" media="screen" href="css/tree.css" /> <script src="javascript/TreeMenu.js" language="JavaScript" type="text/javascript" /> </head> <body> <script language="javascript" type="text/javascript"> objTreeMenu_1 = new TreeMenu("images/tree", "objTreeMenu_1", "pageFrame", "treeMenuDefault", true, false); newNode = objTreeMenu_1.addItem(new TreeNode('MuST Home Page', 'loupe.jpg', 'StartPage.html', false, true, '', '', null)); newNode_1 = newNode.addItem(new TreeNode('Discipline 1', 'folder.gif', null, false, true, '', '', 'folder-expanded.gif')); newNode_2 = newNode.addItem(new TreeNode('Discipline 2', 'folder.gif', null, false, true, '', '', 'folder-expanded.gif')); newNode_3 = newNode.addItem(new TreeNode('Discipline 3', 'folder.gif', null, false, true, '', '', 'folder-expanded.gif')); newNode_3_1 = newNode_3.addItem(new TreeNode('Function 1', 'folder.gif', null, false, true, '', '', 'folder-expanded.gif')); newNode_3_1_1 = newNode_3_1.addItem(new TreeNode('Document 1', 'img-page.gif', null, false, true, '', '', null)); newNode_3_1_1_1 = newNode_3_1_1.addItem(new TreeNode('v1.0', 'pdfIcon.gif', 'document/document1.pdf', false, true, '', '', null)); newNode_4 = newNode.addItem(new TreeNode('Discipline 4', 'folder.gif', null, false, true, '', '', 'folder-expanded.gif')); objTreeMenu_1.drawMenu(); objTreeMenu_1.writeOutput(); objTreeMenu_1.resetBranches(); </script></body> </html> Expected result: ---------------- The code abve should be displayed on the browser Actual result: -------------- The html code above is not displayed in my browser (IE 6.0.2800)

Comments

 [2004-12-03 12:37 UTC] patrick dot tissot at airbus dot com
I just want to add that my problem comes from the IE version. Indeed I have accessed my PHP page (with the HTML_TreeMenu) from a browser IE 5.50.4522 and it works. So what are the modifications to be done (on tree.js file or other file?) in order to have the tree displayed in IE 6.0.2800
 [2004-12-03 13:09 UTC] mike
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the existing bug instead. Thank you for your interest in PEAR. dupe of bug #2881