Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.5.0b5

Bug #2745 Error with autoExecute method
Submitted: 2004-11-13 01:34 UTC
From: rolson at deviantart dot com Assigned: lsmith
Status: Closed Package: MDB2
PHP Version: 4.3.8 OS: FreeBSD 5.0
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 36 - 26 = ?

 
 [2004-11-13 01:34 UTC] rolson at deviantart dot com
Description: ------------ MDB2 Problem with call to bindParamArray from autoExecute method. Reproduce code: --------------- Really lame example I tried just to check. CREATE TABLE tablename ( key varchar(13) not null primary_key, key2 varchar(12) not null); $form_data = array('key' => 'val', 'key2' => 'val2'); $db->extended->autoExecute('tablename', $form_data, array(), array(), MDB2_AUTOQUERY_INSERT); Actual result: -------------- Fatal error: Call to undefined function: bindparamarray() in /usr/home/miu/prj/system/external/MDB2.php on line 2406

Comments

 [2004-11-20 09:40 UTC] smith at backendmedia dot com
Which version of MDB2 are you using? It seems like you are using the CVS version? I am working on a few fixes atm there.
 [2004-11-21 06:19 UTC] rolson at deviantart dot com
Correct, I am using the version out of CVS because there was another bug I encountered that suggested going with the CVS version as a fix. Is there any time estimate on when the autoExecute methods might be working? Thanks!
 [2004-11-21 10:39 UTC] smith at backendmedia dot com
next few days .. I just need to test the fixes in detail.
 [2004-11-22 23:24 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. I dont have a testcase for the autoExecute() but the internal API changes should have now been applied to it ...