Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.4

Bug #2623 bug in SAFE_MODE
Submitted: 2004-10-26 15:13 UTC
From: golan at seznam dot cz Assigned:
Status: Bogus Package: Spreadsheet_Excel_Writer
PHP Version: 4.3.9 OS: LINUX
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 48 - 38 = ?

 
 [2004-10-26 15:13 UTC] golan at seznam dot cz
Description: ------------ there is a bug in safe_mode this object doesnt send data to client when save mode is enabled it's due to using function tempnam in OLE/PPS/File.php this function does'nt work correcly in safe mode

Comments

 [2004-11-19 21:04 UTC] lukasl at ackleymedia dot com
I can verify that this package returns a 0 byte file when using it in safe mode.
 [2004-11-20 20:37 UTC] lukasl at ackleymedia dot com
Well, my host (swiftwill.com) figured this bug out. Turns out this is not a bug, but basically the restrictions of safe_mode in PHP. This package tries to create a file in /tmp/ and based on some safe_mode restrictions, this is where it fails. You can fix this by setting the temporary directory for the file using this function: $workbook->setTempDir($AbsoluteServerPathToTheTempDir); Make sure the directory is chmod 777 This worked for me.
 [2005-01-06 19:44 UTC] tuupola
safe_mode as the name implies restricts usage of several php functions. The functions in question regarding this problem are tempnam() and fopen() http://fi.php.net/manual/en/features.safe-mode.functions.php You can either use the solution Lukas provided or run without safe_mode.
 [2006-04-17 15:10 UTC] fnjordy at gmail dot com (Steven McCoy)
The script calling SpreadSheet_Excel_Writer() needs to have the Safe_mode gid and/or uid, chmod 777 is not sufficient.