Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #249 installing from an url doesnt work
Submitted: 2003-11-14 12:12 UTC
From: smith at backendmedia dot com Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 4.3.3 OS: Windows
Roadmaps: (Not assigned)    
Subscription  


 [2003-11-14 12:12 UTC] smith at backendmedia dot com
Description: ------------ I tried installing a package by specifying the exact URL in order to see if this would ignore the state check (I would expect it to ignore the state). However I got the following results: C:\php>pear install http://pear.php.net/get/LiveUser-0.9.tgz Package name 'http://pear.php.net/get/LiveUser-0.9.tgz' not valid

Comments

 [2003-11-17 05:48 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. I knew it :) The "improvements" to my download code broke things, causing this bug. Shortcuts are always bad no matter how clever. I forgot to make a patch prior to commit. Here's the lines that must be added at line 743 of Installer.php: if (preg_match('#^(http|ftp)://#', $pkgfile)) { $pkgfile = $this->_downloadFile($pkgfile, $config, $options, $errors, $version, $origpkgfile, $state); if (PEAR::isError($pkgfile)) { return $pkgfile; } $tempinfo = $this->infoFromAny($pkgfile); if (isset($options['alldeps']) || isset($options['onlyreqdeps'])) { // ignore dependencies if there are any errors if (!PEAR::isError($tempinfo)) { $mywillinstall[strtolower($tempinfo['package'])] = @$tempinfo['release_deps']; } } $installpackages[] = array('pkg' => $tempinfo['package'], 'file' => $pkgfile, 'info' => $tempinfo); continue; }
 [2004-04-09 22:01 UTC] clay
This bug's status is Closed -- however, I am still experiencing the exact problem described by Lukas as of PEAR 1.3.1. Did this bug reappear since the Nov 17 fix?