Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.16.14

Bug #2431 Bug in examples?
Submitted: 2004-10-01 12:58 UTC
From: jan at ivtaco dot se Assigned: lsmith
Status: Closed Package: LiveUser
PHP Version: Irrelevant OS: Windows XP & Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 9 = ?

 
 [2004-10-01 12:58 UTC] jan at ivtaco dot se
Description: ------------ Hi, My name is Jan Bolmeson and I am the lead developer in a Swedish Software company. We have been looking at LiveUser to implement it in our current development project. The problem is that we can't seem to get the inActive-message working in neither of the examples. The examples work great in Authenticating but as soon as we change the Y with a N or 0 the user is simply not logged in. And the same error message as when you enter a false password occurs. We have tried this on several computers with different configurations, i.e. development box with PHP5 and a production box with PHP4.3.8. Everything else seems to work just fine. Is this something you have experienced as well? If so it is most probably a bug in the TryLogin (line 977 LiveUser.php) function which should set the statusstate to -3 (i think) and not to -9. Thanks in advance, Jan Bolmeson The same error occurs both with the newest and next-newest versions of LiveUser. Reproduce code: --------------- Example 1-5 distributed with LiveUser. Expected result: ---------------- One should get an error-message saying: <h3>Sorry kid, but one of our admins has yet approved your user status. Please be patient. Don't call us - we'll call you.</h3> <p align="center"><a href="example.php?logout=1">Logout</a></p> Actual result: -------------- <h3>Sorry, we can't let you in. Check if the spelling of your handle and password is correct.</h3> <p align="center"><a href="example.php?logout=1">Logout</a></p>

Comments

 [2004-10-01 14:52 UTC] smith at backendmedia dot com
Could you try out the latest CVS version. I just fixed a bug which would result in the problem you are describing. Let me also explain how the in active situation works: LiveUser looks for a user whos handle and password match. If that user is active (in case the optional field is even activated) the uses is logged in. Eitherway LiveUser stops looking for a user to authenticate (remember you can have multiple authentication containers which are checked sequentially). After the login process if the user is not logged in you can check if the user is in active or you can just get the status.
 [2004-10-11 11:26 UTC] smith at backendmedia dot com
I am closing this bug as it seems to be related to the now deprecated 0.12.x release cycle. As we are still in beta we cant maintain older versions yet :-/