Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.1

Bug #1901 Paranthess { } lost...
Submitted: 2004-07-17 07:34 UTC
From: sinan at gamebox dot net Assigned: pajoye
Status: Bogus Package: HTML_Template_IT
PHP Version: 4.3.4 OS: Mandrake 10.0
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 43 - 35 = ?

 
 [2004-07-17 07:34 UTC] sinan at gamebox dot net
Description: ------------ Input paranthesis { lost } ... Reproduce code: --------------- $input = '?_{3}_? {2} any thing else... 1/{2}'; $template->setVariable('MAIN', $input); $template->show(); Expected result: ---------------- ?_{3}_? {2} any thing else... 1/{2} Actual result: -------------- ?__? any thing else... 1/

Comments

 [2004-07-17 15:28 UTC] pierre at dotgeek dot org
Thank you for taking the time to write to us, but this is not a bug. See the manual. Sample code: $tpl = new HTML_Template_IT(); $input = '?_{MAIN}{3}_? {2} any thing else... 1/{2}'; $tpl->setTemplate($input, false, true); $tpl->setVariable('MAIN', $input); $tpl->parse(); $tpl->show(); --Pierre
 [2004-07-19 05:53 UTC] sinan at gamebox dot net
But it is not variable, it just a input string.... So, there is a no problem... $input = '?_{3}_? {2} any thing else... 1/{2}'; $input = strtr($input, array('{'=>'{', '}'=>'}')); $tpl->setTemplate($input, true, true); $tpl->setVariable('MAIN', $input); $tpl->parse(); $tpl->show();