Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.13

Bug #1817 Introduction example does not work
Submitted: 2004-07-07 23:00 UTC
From: aemadrid at gmail dot com Assigned: alan_k
Status: Closed Package: HTML_Template_Flexy
PHP Version: 4.3.7 OS: Linux RH 2.1AS
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 45 - 12 = ?

 
 [2004-07-07 23:00 UTC] aemadrid at gmail dot com
Description: ------------ I'm trying to run the Introduction code and I'm getting an error for a non existing class. I have modified the ini file to include actual directories and hade to include. I had to also include PEAR.php because it was complaining about it (Fatal error: Undefined class name 'pear' in /home/hyperxmedia.net/public_html/flexy/index.php on line 6). I'm using the latest release of Flexy (0.9.2). Reproduce code: --------------- [34] $this->elements['input'] = new HTML_Template_Flexy_Element; Expected result: ---------------- The compiled html code. Actual result: -------------- Fatal error: Cannot instantiate non-existent class: html_template_flexy_element in /home/hyperxmedia.net/public_html/flexy/index.php on line 34

Comments

 [2004-07-08 03:49 UTC] alan_k
The documentation should say require_once 'HTML/Template/Flexy/Element.php'; before line [34] AFAIK the PEAR.php issue is fixed in CVS
 [2004-07-08 15:47 UTC] aemadrid at gmail dot com
Thanks for the information. I suspected it. Is there a tutorial anywhere? Looking at the tests there seems to be a bunch of different syntaxes supported. It'd be great to have a tutorial explaining all these features and when are better used. BTW, I had to comment out line #51 (array_shift($a);) to make the tests work.
 [2004-07-24 04:33 UTC] alan_k
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. have a look at the tests for more examples http://cvs.php.net/pear/HTML_Template_Flexy/tests/