Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.0a3

Bug #16922 bad minimum reqirements - getopt
Submitted: 2009-12-18 01:02 UTC
From: mckinzey Assigned: hm2k
Status: Closed Package: PHP_Compat (version CVS)
PHP Version: 5.3.1 OS:
Roadmaps: 1.6.0a3    

 [2009-12-18 01:02 UTC] mckinzey (John McKinzey)
Description: ------------ According to the comments in that code, getopt has been available since 4.0.4. According to, however, getopt has only been available since 4.3.0. Further, according to, getopt was, as of 5.3.0, "no longer system dependent and works on Windows too". It seems like that ought to be reflected, too, in the @since thing, but I'm not sure how it would be reflected.


 [2009-12-20 18:21 UTC] doconnor (Daniel O'Connor)
-Summary: bad minimum reqirements +Summary: bad minimum reqirements - getopt
 [2010-07-27 18:14 UTC] hm2k (James Wade)
Corrected getopt() since 4.0.4 > 4.3.0 It was already correct in Components.php At revision: 301612
 [2010-07-27 18:14 UTC] hm2k (James Wade)
-Status: Open +Status: Closed -Assigned To: +Assigned To: hm2k