Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.0.4

Request #16787 default 'latin1_swedish_ci' db created with collation set to utf8_unicode_ci
Submitted: 2009-11-13 22:47 UTC
From: fzhan Assigned: quipo
Status: Closed Package: Translation2 (version 2.0.1)
PHP Version: 5.3.0 OS: linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 20 - 14 = ?

 
 [2009-11-13 22:47 UTC] fzhan (Fan Zhang)
Description: ------------ protected static $lang_params = array ( 'langs_avail_table' => 'i18n', 'lang_id_col' => 'id', 'lang_name_col' => 'name', 'lang_meta_col' => 'meta', 'lang_errmsg_col' => 'error_text', 'lang_encoding_col' => 'encoding', 'strings_default_table' => 'language_db', 'string_id_col' => 'id', 'string_page_id_col' => 'page_id', 'string_page_id_col_length' => 50, // db field size 'string_text_col' => '%s', //'%s' will be replaced by the lang code 'charset' => 'utf8', 'collation' => 'utf8_unicode_ci', ); ... $dbinfo = parent::$dsn; $dbinfo['database'] = parent::$databaseName; $tr = new Translation2_Admin(); $tr = $tr->factory('MDB2',$dbinfo,self::$lang_params); $tr->setCharset('utf8'); $new_lang = array( 'lang_id' => $pm_language, 'table_name' => self::$table_translation_system, 'name' => $pm_string, 'meta' => $meta, 'error_text' => $error_text, 'encoding' => 'UTF-8', ); $lang_options = array ( 'charset' => 'utf8', 'collation' => 'utf8_unicode_ci', ); if ($tr->addLang($new_lang, $lang_options)) {.... Expected result: ---------------- Database table should be created in utf8_unicode_ci. Actual result: -------------- Both i18n and language_db have been created with 'latin1_swedish_ci' collation

Comments

 [2009-12-28 03:27 UTC] quipo (Lorenzo Alberton)
-Status: Open +Status: Closed -Assigned To: +Assigned To: quipo
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.