Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.6.2

Bug #16054 phpcs-svn-pre-commit not showing any errors
Submitted: 2009-03-24 02:25 UTC
From: str Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.2.0RC1)
PHP Version: 5.2.9 OS: Ubuntu
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 46 - 32 = ?

 
 [2009-03-24 02:25 UTC] str (Stuardo Rodríguez)
Description: ------------ I'm testing the precomit hook as it is shown on the documentation. It force it to exit, becase I never get any error. The php file I'm testing is a very simple one, but if violates a lot of rules. Test script: --------------- <?php class test { public function test(){ echo 'hola mundo'; } } $test = new test(); $test->test(); /usr/bin/scripts/phpcs-svn-pre-commit --standard=Squiz --tab-width=4 "$REPOS" -t "$TXN" 1>&2 || exit 1 exit 3 Expected result: ---------------- exit 1 Actual result: -------------- exit3

Comments

 [2009-03-25 08:31 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Verified -Assigned To: +Assigned To: squiz
 [2009-03-25 08:56 UTC] squiz (Greg Sherwood)
-Status: Verified +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.