Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.31.0

Bug #16038 Links in manual header/footer are double encoded
Submitted: 2009-03-16 22:59 UTC
From: wiesemann Assigned: cweiske
Status: Closed Package: pearweb (version CVS)
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2009-03-16 22:59 UTC] wiesemann (Mark Wiesemann)
Description: ------------ The "previous"/"next" links in the header and footer navigation bars of all manual pages are double encoded. First time by phd, second time by a htmlspecialchars() call in include/pear-manual.php. The problem doesn't exist for the same target in the sidebar (there is no htmlspecialchars() call for these links). Example ("next" link: """ instead of """): http://pear.php.net/manual/en/package.html.pager.intro.php

Comments

 [2009-03-16 23:01 UTC] wiesemann (Mark Wiesemann)
My example HTML code was replaced in the bug tracker. But the problem is obvious by following the link to the manual page.
 [2009-03-22 15:59 UTC] cweiske (Christian Weiske)
-Status: Open +Status: Closed -Assigned To: +Assigned To: cweiske
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.