Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #13606 parameter name and description do not line up in generated docs
Submitted: 2008-04-06 03:34 UTC
From: gauthierm Assigned: ashnazg
Status: Closed Package: PhpDocumentor
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: 1.4.4    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 14 + 11 = ?

 
 [2008-04-06 03:34 UTC] gauthierm (Michael Gauthier)
Description: ------------ See attached screenshots. The first screenshot is the current generated documentation. The second screenshot has 'vertical-align: top;' applied to all td elements.

Comments

 [2008-04-06 12:19 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This is not a problem in pearweb but in the templates phpdocumentor supplies if I understand correctly how that beast works ... Over to Chuck now.
 [2009-10-12 20:18 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: ashnazg
Michael, can you point me directly to a URL where this is evident right now in peardoc? I need to be sure I'm looking at the correct thing.
 [2009-11-24 02:48 UTC] ashnazg (Chuck Burgess)
Michael, is this oddity still visible somewhere to you? I've tried duplicating with all the HTML output converters, and when I shrink the browser enough to cause the descriptions to linewrap, they line up perfectly for me.
 [2009-11-24 04:52 UTC] gauthierm (Michael Gauthier)
Chuck, The problem is still present and is quite visible on http://pear.php.net/package/Crypt_GPG/docs/1.0.0/Crypt_GPG/Crypt_GPG.html#me thodgetFingerprint (http://bit.ly/5Whvai) The documentation for the $format parameter actually starts with "optional. How the fingerprint should be formatted..." but the line points to "Crypt_GPG::FORMAT_NONE". It makes it appear as if the documentation for the second parameter is actually part of the first parameter's documentation. The problem is still solvable by applying a "vertical-align: top;" style to the td cells that display parameter documentation.
 [2009-11-24 19:16 UTC] ashnazg (Chuck Burgess)
Ah, that helps... The root issue seems to be 'centered' vertical alignment, so changing that to 'top' probably will solve it. Need to find a way to test this on sg1 box.
 [2009-11-24 19:19 UTC] ashnazg (Chuck Burgess)
-Status: Feedback +Status: Verified
 [2009-11-24 23:02 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Closed -Roadmap Versions: 1.4.4 +Roadmap Versions: 1.5.0a1
Updated this in the HTML:Smarty:PEAR output converter... committed to SVN.
 [2011-12-01 03:26 UTC] ashnazg (Chuck Burgess)
-Roadmap Versions: 1.5.0a1 +Roadmap Versions: 1.4.4