Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.5

Bug #12930 function crop() should not set resized=true
Submitted: 2008-01-18 16:28 UTC
From: sharedlog Assigned:
Status: Wont fix Package: Image_Transform (version 0.9.1)
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 9 - 6 = ?

 
 [2008-01-18 16:28 UTC] sharedlog (Dmitri Snytkine)
Description: ------------ The function crop() should not set $this->resized=true at the end This is because crop() does not really resize an image, it cuts out the smaller rectangle area from a larger image. Second and most important reason - what if I want to cut out an area of a large image with crop() and then resize this rectangle to a thumbnail (for example) Right now it will not be possible to use $i->crop() $i->resize() because crop() sets $this->resized to true and with this variable set to true it's not possible to resize again.

Comments

 [2008-03-22 08:58 UTC] doconnor (Daniel O'Connor)
Dmitri, Can you provide a bit more reproduce code? I suspect the answer to this is a simple $this->altered instead of $this->resized; but I'm not familiar with the package enough to fix it
 [2008-04-28 12:09 UTC] cweiske (Christian Weiske)
The package internals are laid out in a way that does not allow combining several actions without reloading the pictures. So "resized" is not just an resizing indicator but a global status variable that should not be overridden.