Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #12733 Warning in error.html file with XML:DocBook:peardoc2
Submitted: 2007-12-19 21:59 UTC
From: rudis Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.4.1)
PHP Version: 5.2.5 OS: Mac OS X 10.4
Roadmaps: 1.5.0a1    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 38 - 35 = ?

 
 [2007-12-19 21:59 UTC] rudis (Simon Ruderich)
Description: ------------ Hi, I'm using PhpDocumentor with XML:DocBook:peardoc2 with the following option: --output XML:DocBook/peardoc2:default The problem is that the errors.html file contains the following errors: Warning: Smarty error: unable to read resource: "header.tpl" in /Library/WebServer/Documents/util/phpdocumentor/phpDocumentor/Smarty-2.6.0/libs/Smarty.class.php on line 1144 Warning: Smarty error: unable to read resource: "footer.tpl" in /Library/WebServer/Documents/util/phpdocumentor/phpDocumentor/Smarty-2.6.0/libs/Smarty.class.php on line 1144 This happens because the "header.tpl" and "footer.tpl" files don't exist in phpDocumentor/Converters/XML/DocBook/peardoc2/templates/default/templates/. To fix it they have to be added and then everything works fine. Maybe errors.xml should be generated instead of errors.html with valid XML code in it which can be easily parsed. Thanks, Simon

Comments

 [2009-10-12 20:19 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Verified
 [2011-12-01 03:29 UTC] ashnazg (Chuck Burgess)
-Roadmap Versions: 1.4.4 +Roadmap Versions: 1.4.5
 [2012-09-01 02:33 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Wont fix -Assigned To: +Assigned To: ashnazg -Roadmap Versions: 1.4.5 +Roadmap Versions:
No more feature work on phpDocumentor 1.x. Check out the new phpDocumentor 2.x (http://www.phpdoc.org/).
 [2012-09-02 01:42 UTC] ashnazg (Chuck Burgess)
-Status: Wont fix +Status: Closed -Roadmap Versions: +Roadmap Versions: 1.5.0a1
Able to fix this using empty header.tpl and footer.tpl files, since Smarty code can't be edited to not expect their existence. Including this fix for 1.5.0a1.