Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #1163 pear makerpm fails with packages that provide role="doc"
Submitted: 2004-04-08 13:15 UTC
From: dseg at shield dot jp Assigned: cellog
Status: Closed Package: PEAR
PHP Version: 4.3.4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 12 - 10 = ?

 
 [2004-04-08 13:15 UTC] dseg at shield dot jp
Description: ------------ http://news.php.net/article.php?group=php.pear.dev&article=27134 ** Patches for template.spec, PEAR/Command/Package.phpincluded ** o When trying to build rpms from pear packages(.tgz) by issuing command '/usr/bin/pear makerpm <package.tgz>', document files listed in packages.xml was not added to rpm as expected in some packages. o Due to other reason, documentations of DB-1.6.1.tgz also not added to rpm. From packages.xml of DB-1.6.1: (...) <file role="doc" name="doc\IDEAS"/> <file role="doc" name="doc\MAINTAINERS"/> <file role="doc" name="doc\STATUS"/> <file role="doc" name="doc\TESTERS"/> (...) '\' used for directory separator, but no translation was done when generating the spec file so resulting spec file contains '\' as directory separator. This is not good on unix platform. I think '\' should be replaced to php constant DIRECTORY_SEPARATOR in PEAR/Command/Package.php. o When trying to uninstall rpms, error occurred. Reproduce code: --------------- http://news.php.net/article.php?group=php.pear.dev&article=27134 Expected result: ---------------- <package_root>/docs/* should be added to rpm. <package_root>/examples/* should be added to rpm. Documentations listed in package.xml as 'doc\foo' should be treated as 'doc/foo' on *nix platform. (rpm run on *nix) rpm -e <package-name> should be exit without errors. Actual result: -------------- http://news.php.net/article.php?group=php.pear.dev&article=27134

Comments

 [2004-04-08 13:17 UTC] dseg at shield dot jp
Description: ------------ http://news.php.net/article.php?group=php.pear.dev&article=27134 ** Patches for template.spec, PEAR/Command/Package.php are included ** o When trying to build rpms from pear packages(.tgz) by issuing command '/usr/bin/pear makerpm <package.tgz>', document files listed in packages.xml was not added to rpm as expected in some packages. o Due to other reason, documentations of DB-1.6.1.tgz also not added to rpm. From packages.xml of DB-1.6.1: (...) <file role="doc" name="doc\IDEAS"/> <file role="doc" name="doc\MAINTAINERS"/> <file role="doc" name="doc\STATUS"/> <file role="doc" name="doc\TESTERS"/> (...) '\' used for directory separator, but no translation was done when generating the spec file so resulting spec file contains '\' as directory separator. This is not good on unix platform. I think '\' should be replaced to php constant DIRECTORY_SEPARATOR in PEAR/Command/Package.php. o When trying to uninstall rpms, error occurred. Reproduce code: --------------- http://news.php.net/article.php?group=php.pear.dev&article=27134 Expected result: ---------------- <package_root>/docs/* should be added to rpm. <package_root>/examples/* should be added to rpm. Documentations listed in package.xml as 'doc\foo' should be treated as 'doc/foo' on *nix platform. (rpm run on *nix) rpm -e <package-name> should be exit without errors. Actual result: -------------- http://news.php.net/article.php?group=php.pear.dev&article=27134
 [2004-04-08 13:24 UTC] dseg at shield dot jp
Description: ------------ http://news.php.net/article.php?group=php.pear.dev&article=27134 ** Patches for template.spec, PEAR/Command/Package.php are included ** o When trying to build rpms from pear packages(.tgz) by issuing command '/usr/bin/pear makerpm <package.tgz>', document files listed in packages.xml was not added to rpm as expected in some packages. o Due to other reason, documentations of DB-1.6.1.tgz also not added to rpm. From packages.xml of DB-1.6.1: (...) <file role="doc" name="doc\IDEAS"/> <file role="doc" name="doc\MAINTAINERS"/> <file role="doc" name="doc\STATUS"/> <file role="doc" name="doc\TESTERS"/> (...) '\' used for directory separator, but no translation was done when generating the spec file so resulting spec file contains '\' as directory separator. This is not good on unix platform. I think '\' should be replaced to php constant DIRECTORY_SEPARATOR in PEAR/Command/Package.php. o When trying to uninstall rpms, error occurred. Reproduce code: --------------- http://news.php.net/article.php?group=php.pear.dev&article=27134 Expected result: ---------------- <package_root>/docs/* should be added to rpm. <package_root>/examples/* should be added to rpm. Documentations listed in package.xml as 'doc\foo' should be treated as 'doc/foo' on *nix platform. (rpm run on *nix) rpm -e <package-name> should be exit without errors. Actual result: -------------- http://news.php.net/article.php?group=php.pear.dev&article=27134 -- Sorry about duplicate posts.
 [2004-06-08 18:17 UTC] cellog
fixed the code portion. I don't have capacity to test the rpm spec, could someone else verify this one? Greg
 [2004-07-12 11:06 UTC] wtatam at premierit dot com
What is happening about this bug ? We are now on 4.3.7 and it still has not been fixed. What is causing the delay ?
 [2004-08-04 15:03 UTC] jellybob at gmail dot com
Attempting to run pear makerpm on a package now results in the following output. jon@georgie:~/pear/Auth_PrefManager2$ pear makerpm package.xml Invalid checksum for file "<?xml version="1.0" encoding="ISO-8859-1" ?> <!DOCTYPE package SYSTEM "http://pear.php.net/dtd/packa" : 44623 calculated, 0 expected
 [2004-10-22 04:59 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. finally got around to checking this one out. Fixed for PEAR 1.3.2 (coming soon)