Report new bug | New search | Development Roadmap Status: Open | Feedback | All

Bug #1109 PATCH: manual navigation bar HTML tags not balanced
Submitted: 2004-03-31 20:23 UTC
From: danielc Assigned: mj
Status: Closed Package: Web Site
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 2 + 49 = ?

 
 [2004-03-31 20:23 UTC] danielc
Description: ------------ There are imbalanced HTML tags in the top navigation bar of the manual. This is caused by a boo-boo in the navigationBar() function in pearweb/include/pear-manual.php. Here is a patch that both fixes this problem and tidys up the HTML output so one can clearly see what's going on when making future changes. http://www.analysisandsolutions.com/pear/include.manual.balance.diff Reproduce code: --------------- Go to any manual page, such as http://pear.php.net/manual/en/package.database.php Look at the source of the language navigation bar. Expected result: ---------------- ... snip ... <td align="right"> <small>Last updated: Sun, 28 Mar 2004</small> </td> </tr> </table> Actual result: -------------- ... snip ... <td align="right"> <small>Last updated: Sun, 28 Mar 2004</small> </td> </tr> </small></td></tr></table>

Comments

 [2004-04-01 06:04 UTC] mj
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.